GTK+2 panel 

GTK+2 panel Commit Details

Date:2012-05-27 11:03:01 (8 years 5 months ago)
Author:Nicola Fontana
Branch:master
Commit:85ba0df42dd1719d57a585825763fc09fdab2fbc
Parents: 4709bf15a2260570683255c80e8bbe1d5fa8c6a4
Message:[widgets] Added explicit dependency to libwnck

When linking with the --as-needed option enabled, the interlibraries
dependencies must be explicitely set. Check this link for details:
http://www.gentoo.org/proj/en/qa/asneeded.xml

Closes issue #68.
Changes:
Mlibgpwidgets/Makefile.am (2 diffs)

File differences

libgpwidgets/Makefile.am
5656
5757
5858
59
5960
6061
6162
......
7475
7576
7677
78
7779
7880
7981
$(built_c_sources)
EXTRA_libgpwidgets_la_SOURCES=$(extra_c_sources)
libgpwidgets_la_LDFLAGS=-shared
libgpwidgets_la_LIBADD=
if HAVE_GLADE
if HAVE_LIBWNCK
libgpwidgets_la_SOURCES +=$(libwnck_c_sources)
libgpwidgets_la_LIBADD +=$(LIBWNCK_LIBS)
pattern=/<!-- if libwnck -->/d;/<!-- endif -->/d;
else

Archive Download the corresponding diff file

Branches

Tags