silverstripe-carousel 

Issue 165: No dimensions given when resizing image

Reported by Nigel Crossley, Jan 28, 2016

Hi

Please see the attached image. It should have most, if not all the 
info you need.

I'm using server has Php 5.6 and Silverstripe 3.1.16

I've installed silverstripe-carousel, sortable file and 
silverstripe-gallery. 

When I create a gallery page and set the Image width and Height it 
remains at 0 on save. The thumbnail settings do save.

I have tried using the settings below in the 
mysite/_config/config.yml file.

Name: DefaultSettings
After:
  - 'gallery/*'

GalleryPage:
  defaults:
    Captions: false
    Width: 1200
    Height: 1000
    ThumbnailWidth: 140
    ThumbnailHeight: 140


I've also tried some other settings, with no luck.

Comment 1 by Nicola Fontana, Jan 28, 2016

Hi Nigel, thanks for the report.

The YAML settings should affect only new galleries, they are just 
fallback values to help on the CMS side when you have tons of 
galleries with the same settings.

The problem still stands. I need more info though:

1.
Did you run dev/build and ?flush after the installation?

2.
Did you use composer for installation? Can I see the relevant 
portion of composer.json?

3.
If not using composer I need to know Which version of 
silverstripe-carousel and sortablefile you installed.
Owner: ntd

Comment 2 by Nigel Crossley, Jan 28, 2016

Hi

Thanks for such a quick reply.

1. Yes /dev/build?flush=ALL was used
2. It was uploaded using ftp and is in /silverstripe-gallery then 
running /dev/build?flush=ALL
3. I'm not sure of the version numbers but silverstripe-carousel was 
the version from https://github.com/ntd/silverstripe-carousel and 
sortable file from https://github.com/bummzack/sortablefile

I did install the gallery before realising that I needed 
silverstripe-carousel I don't know if doing them in the wrong order 
would cause any issues.

I tried creating a new gallery page to see if the yaml made any 
difference but it didn't.

Comment 3 by Nicola Fontana, Jan 28, 2016

Sorry, I am unable to replicate the issue (see attachment).

I just created a composer.json that pulls in silverstripe 3.1.6 and 
the master branches of sortablefile, silverstripe-carousel and 
silverstripe-gallery:

{
    "require": {
        "silverstripe/framework": "3.1.16",
        "silverstripe/cms": "3.1.16",
        "bummzack/sortablefile": "dev-master",
        "entidi/silverstripe-carousel": "dev-master 
as 2.2.x-dev",
        "entidi/silverstripe-gallery": 
"dev-master"
    }
}

After having created a dummy "mysite" and running a 
"composer update" everything works as expected.

My base directory is as following (* are composer related):

assets
carousel
cms
composer.json *
composer.lock *
framework
gallery
mysite
sortablefile
vendor *

My wild guess is your devbuild is failing (double check after a 
dev/build you see the "Database build completed!" message 
at the end) or you have something messed up on your deployment.

Comment 4 by Nicola Fontana, Jan 28, 2016

Obviously I forgot the attachment :)

Comment 5 by Nigel Crossley, Jan 28, 2016

Thank you for trying.. I'll try deleting the gallery database and 
doing the database build again.

Comment 6 by Nigel Crossley, Jan 28, 2016

I just wanted to update you.. The issue appears to be in 
silverstripe-carousel. If I override the height and width settings 
in the database it works but will not save any changes in the admin. 
 I've tried deleting and re-installing both the files and database 
with no luck.

Thanks for your help. I'm afraid I'll have to use a different 
gallery for now.

Comment 7 by Nicola Fontana, Jan 28, 2016

Ok, thank you for the feedback.
Status: Invalid

Created: 4 years 5 months ago by Nigel Crossley

Updated: 4 years 5 months ago

Status: Invalid

Owner: Nicola Fontana

Labels:
Priority:Medium
Type:Defect